Rpa center on Windows server 2016?

Hi, the compatibility for Rpa center is indicated in the manual as windows 7 or higher.
Is it ok to install on a Windows server 2016?

Yes, it is compatible with Windows 2016.